• Hello, If you are looking for the YouTuber Special Camp - Gregg Virgoe Meetup please CLICK HERE

Yellow warning light

bobj808

Full Member

Messages
91
The engine management light has been off/on for over 2 years now on our 2009 Ducato base. It can be turned off by starting/stopping engine 5 times. Will stay off for hundreds of miles then comes on again. Motor runs perfectly and starts easily. Last annual service garage couldn't read any faults. Doesn't particularly bother me, can be as simple as very slight leak in exhaust.
 

Vanterrier

Full Member

Messages
1,184
Ah, but what about the occasional failure to start until it has been cranked five times though?
I'll be home in a week with a bit of luck then I can get a reader on it...
Watch this space
K ;)
 

bobj808

Full Member

Messages
91
Ah, perhaps misread your post. Mine's always starts first turn of key, but if I immediately turn it off and then start again x 5 then the light goes out. Used to do this but don't bother now. Was trying to put your mind at ease, but you may have another issue, as this light covers so many things. Good luck, sure all will be well for getting home. Bob.
 

bobj808

Full Member

Messages
91
Aldi selling a code reader on Sunday for 16.99. I'm going to get one to turn the light off + the one on my Fiesta which has been on for ages. Garage turned it off last service, said there's no faults but it came back on next day. Bob
 

Vanterrier

Full Member

Messages
1,184
Got home ok with no further problems starting although the light came on one more time and went outcafter 5 restarts.
When it stops raining I will get my reader on it.
K ;)
 

Vanterrier

Full Member

Messages
1,184
Right, the sun came out at last and I connected the OBD reader and got a P0638 code. There was no warning light on at the beginning of this test.
I decided to erase the code to see if it returned.
I removed the reader.
I reconnected the reader and switched the ignition on and saw straight away that the warning light came back on AND the passengers airbag is deactivated light came on ???
When I read the codes again I now have two. Both P0638 but with one additionally showing "Pending" meaning it needs a few more occurrences before it becomes an active code.
So, what does all this mean?
See link attached for a very comprehensive and slightly scary description.
For me, it looks like I need to remove the throttle body and give it a good old clean and hope that's the end of it.
Wish me luck.
K 😟
 

Vanterrier

Full Member

Messages
1,184
Small update... The passenger airbag has been turned on again via the programming switch and the light has gone out so I am just left with the original light now.
K ;)
 

Yeoblade

Full Member

Messages
25
Right, the sun came out at last and I connected the OBD reader and got a P0638 code. There was no warning light on at the beginning of this test.
I decided to erase the code to see if it returned.
I removed the reader.
I reconnected the reader and switched the ignition on and saw straight away that the warning light came back on AND the passengers airbag is deactivated light came on ???
When I read the codes again I now have two. Both P0638 but with one additionally showing "Pending" meaning it needs a few more occurrences before it becomes an active code.
So, what does all this mean?
See link attached for a very comprehensive and slightly scary description.
For me, it looks like I need to remove the throttle body and give it a good old clean and hope that's the end of it.
Wish me luck.
K 😟
Had to replace the throttle body on mine last year, actuator failed on it, water drip in on it from the sh1t design windscreen skuttle on the X250. Bit a job to do as the mounting bolts can be a barsteward to remove without shearing them. Not sure there is much you can clean on it that I could see, just replaced it.
 

Vanterrier

Full Member

Messages
1,184
Ok. Stripped throttle body actuator off and cleaned it as best I could. There was some crud but not as bad as I expected. See pictures...
Reassembled and started her up and Bingo! The yellow light went out😎
Whether it stays out ot not we'll see. MOT due in next few weeks and one short trip planned so time will tell.
Pictures below for anyone to follow. Note the T27 needs to have the centre hole if your bolts have the wee pip in the middle of the socket
HTH
K ;)

20191003_101456.jpg20191003_101510.jpg20191003_102511.jpg20191003_103622.jpg20191003_094211.jpg
 
Last edited:

Markd

Full Member

Messages
344
Good to hear - no doubt a garage would have recommended replacement at ££.
To be fair if you are paying a professional for work that may not be successful replacement often makes sense.
I reckon it's always worth a try oneself and if it doesn't work then you can always buy a replacement - which needn't be brand new.
 

Yeoblade

Full Member

Messages
25
Looks quite different to the one fitted on mine, a 2012, 2.3 130bhp X250.
Did you get the cover off it without removing the throttle body from the engine?
 

Vanterrier

Full Member

Messages
1,184
Yes the relay came off the throttle body pretty easily really. Space was tight but ok. Had to remove one air inlet pipe to improve access.
This is the Multijet 160 3.0 X250.
K ;)
 

Vanterrier

Full Member

Messages
1,184
Have since sealed the windscreen to scuttle join with Sikaflex 212 and created a drain to take away the water that used to build up in the nearside scuttle section which then overflowed through the overlapping join between the two scuttle sections and then down onto the throttle. Much better now so hpefully thats that sorted
K ;)
 

Yeoblade

Full Member

Messages
25
Amazing design the :( the two parts of the skuttle joining with a bit foam, really watertight !!!!!!.
Have you already got the fiat recall part fitted, the plastic engine cover (umbrella :)) Didn't help much on mine as the throttle actuator failed due to the water ingress.
 

Vanterrier

Full Member

Messages
1,184
Yes I have the plastic engine cover which presumably was designed to direct the water over the engine and onto the throttle 😩
Checked this morning after overnight rain and its as dry as a ferrets armpit.
K 👍
 

Users who viewed this discussion (Total:176)

Ian1950, Tezza33, St3v3, Val54, Edward B, Bouydog, rugbyken, silverweed, jeffmossy, Edina, grath, HurricaneSmith, Molly 3, GreggBear, 47643, The laird, helmit, Ardachaidh, 2cv, dochiley, Chris356, TeamRienza, Markd, Budgie, RV2MAX, Clunegapyears, eurajohn, Exwindsurfer, Bigshug, Wooie1958, clarkpeacock, Biggarmac, Carrotts, Carrerasax, Barge1914, PeteS, mark61, Greengrass, VWann, Chris Evans001, abmnw, tapfitter, Telstar, bobj808, IscubaToo, Mark135, wints, Sueben, Trappers, shabbins, helen262, Crystalight, Amudle, alun100, Burgo, On a journey, guerdeval, Asterix, walpeter, Taurian, LANDS43, Alf, Tuppence, john and janet, nabsim, Haaamster, Matchlock, nutts, wildebus, 11ALB, yorkieowl, skippy, jonscase, Blackwatch, davidb, Nosmo king, Forest1, H Traveller, ironduck, davidjlambert, DorisBoris, snapster, MollsPhot, WildCamper, oldal, alca, AndyJL, in h, Diver1swife, Travkiwi, Northumborman, MrRush, Codge, PopesOnTour, Yorkscol, Munchkins, scouter, Wrp, Ratface, rongrundy, Dunfillin, gillypoof, Neodafyd, bullfist, Mr K2, Robin McHood, mdennison, paulhelenwilko, Master, raggeevets, pedro, cowanhouse, Tony Lee, polar bear, roadroamer, Yeoblade, Linda, pj650, ibs7491, Samsda, g1dol, cronkle, Rumour, Edmo, GeoffL, davidrtd, Bootlegger66, Andyshep, timatabsa, Mark B, desidog, Ginfearsdad, johnmac185, Berniem, IJenk52, Four Oaks Man, Caz, Grouchy, LENCHEN, seagoon, pagey, Mr&Mrs Tupcox, Daiharley, jwh268, WildThingsKev, V1nny, brianthesnail, 5andy, Rong, Rec, SteveGerry, betsy22, ianmaxim, Dj cooler co, stewpot, Captain Haddock, forthpilot, Stevie, Colchester, Campervanannie, ian and cath, Ted, GDF, Amk, yorkslass, Fdhadi, Jackslad, Sharon Crompton, vincevw, bjh, Mojays, Adriandp, Royal turkey, steve strange, sydnsue, Tidewatcher,
Top